9

Design updates are live!

A majority of the changes will not be visible (except for tweaks to the header that were made to condense the space to get the question list higher); these tweaks go along with recent updates that were made to Stack Overflow:

  • We are moving the site's CSS to a newly refactored LESS system, so that it's easier for us to fix SE network CSS bugs globally and launch new features in the future.
  • We are updating the graphics to SVG for retina support.
  • We've fixed a LOT of obscure bugs that arose when new features were not thoroughly tested across the entire network.
  • We will be able to launch a shiny new user profile!

Visually it should "feel" the same as the old site with slight layout adjustments.

This update should retro-actively fix most of the old design bugs. If you see any new bugs, or old ones not yet fixed, please post an answer here to let us know!

  • @Yes And didn't really do any improvement either… – bjb568 May 21 '15 at 4:44
  • Any news on whether the house is coming back or not? – ChrisF Jun 24 '15 at 16:19
  • @ChrisF sorry it took so long — The house has been restored with only a few minor updates. – Kurtis Beavers Jul 6 '15 at 19:47
11

MAJOR BUG REPORT

The house has vanished. How does a whole house vanish out of no where?

The meta house was extremely cool with the bloody meta written on it!

Please find our DIY house and bring it back!

  • 7
    That's one hell of a sinkhole. – Shog9 May 6 '15 at 1:44
  • @Shog9 - Must reside in Florida somewhere ... – Pᴀᴜʟsᴛᴇʀ2 May 10 '15 at 1:30
  • I have it on good authority that the house will return. – ChrisF Jul 1 '15 at 9:39
  • The house has been restored with only a few minor updates. – Kurtis Beavers Jul 6 '15 at 18:46
4

Ever since an upgrade a few days ago this Home Improvement site has been running super crappy in FF - all other browsers it is fine. The site locks up constantly and takes 10-15 seconds to load sometimes. I am behind a proxy server most of the time so it could be something that is loading through our firewalls quickly, but I don't have any issues with other SE sites and like I said other browsers work fine - checked in IE11, Chrome, Safari. Anyone else having problems?

I am not really seeing much go on during the hang state. Right before the hang state I get a console error "The connection to wss://qa.sockets.stackexchange.com was interrupted...". It then handles trying to load all of the extensions. It hangs every time I visit DIY or DIY meta and no other SE sites. It also hangs every time so not intermittent at all.

Update: Site is basically unusable in FF (W7 64). In IE11 it is definitely loading slower than other SE sites but not a huge deal (.5-1 second vs instant).

As @ratchet freak gave an answer I also noticed the slow sidebar. But that is across all browsers. The issue I am having is that the site is unusable in FF to me and Steve mentioned that it is like that in Chrome to him.

Also another weird behavior was noticed today. I haven't used site as much lately because of the issues. But brought it up in IE11 today. Logged in. Answered a few questions... Saw that I had an answer with a comment on another SE site. Clicked on the other SE site to open in new tab. Took me to the answer and I am not logged into the site and I didn't see the common "refresh" login bar that I would normally see. First time this has ever happened. I suspect that part of the core SE was not uploaded correctly during the last update.

3

Under firefox the site runs rather badly.

A profile run when reloading the newest questions list shows that 1.7 to 2 seconds is spent in sidebar/ which calls d which calls f during which the fps drops to 0:

enter image description here

  • Thanks for your post. The performance of the sidebar wouldn't have anything to do with the recent CSS updates. Would you mind posting this as a separate DIY meta question? – Kurtis Beavers May 11 '15 at 11:07
  • @KurtisBeavers I added the information to the existing meta question regarding performance issues on FF – ratchet freak May 11 '15 at 11:12
1

The voting arrows and favorite star move to the right when clicked; same issues that I previously reported on Stats.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .